Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble

How to *disable* automatic reboots in Windows 10?

Recommended Posts

Windows 10 lets you 'schedule' a reboot for later. I want to disable it.

Evidently Windows scheduled itself for a reboot last night when I wasn't looking and just closed everything I had been working on the night before.

I reboot on the regular; I don't need Windows to do that for me.

Can I disable it completely? I don't mind if it downloads everything, and then says "hey, you should reboot," but it should never reboot itself, ever.

I'm using the "Pro" edition of Windows 10.

Share this post

Link to post
Share on other sites

Note: Unfortunately this appears to not work on Windows 10 Home, and I'm note sure of a workable solution for users of this edition.

I posted this as an answer on another question, but as that appears to be a duplicate of this question I'll provide it here too:

You can edit your local group policy settings to force Windows update to only download updates, but wait for your input to install (and therefore reboot.)

Open you start menu and type Group, then click Edit group policy

Expand Computer Configuration \ Administrative Templates \ Windows Components \ Windows Update

Local Group Policy Editor - Windows Update

Double click Configure Automatic Updates and enable the policy, and configure it as needed.

Configure Automatic Updates

Head back to Windows Update and click Check for updates, once it is done click on the Advanced options

You should see your new settings being 'enforced.'

Enforced Windows Update settings

After applying this setting on a test VM, I left Windows Update open and noticed it start downloading.

Windows Update Downloading

When it finished downloading, you get a toast notification that there are updates and you need to install them.

Windows Update manual install

Note that you must click install now. Restarting or shutting down from the start menu does not appear to trigger the install process.

More info:

I'm not sure if editing Local Group Policy is an option in the Home edition of Windows 10, but the same result should be possible through the registry (I haven't tested this as I used the policy method myself.) Including this in case non-pro users come looking for an answer too.

  1. Press Win + R and type regedit then hit Enter
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU
    (you may need to create the keys manually if they don't exist)
  3. Create a new DWORD value called AUOptions and enter a value of either 2 or 3.

    2 = Notify before download
    3 = Automatically download and notify of installation

  4. Restart PC

  5. Check for updates
  6. Inspect Advanced Settings

Update following Anniversary Update (1607):

I've seen a lot a few comments lately from people saying this no longer works after the Anniversary Update.

I've been running some tests, detailed in the two blog posts here:

These tests have been running for nearly three weeks and I am yet to see any forced reboots.

In light of these results, it appears that this does still work.

Windows 10 Professions Screenshot - 20 Days up time

Things to keep in mind:

  • I did not set any settings around Active Hours or the Reboot Options.
  • DO NOT click the 'Install now' button within the Windows Update UI unless you're ready to install and reboot. Once the updates are installed, there is no stopping Windows from deciding to reboot.
  • Windows will nag you with Toasts, Action Center alerts and banners across your screen. As long as you don't install the updates you're fine (but do do them eventually.)




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.